centos 7 安装 phpmyadmin 并启动远程连接

连接VPS yum install httpd -y //安装apche systemctl start httpd //启动httpd yum install php //安装php sudo yum install epel-release //安装所需的库 yum install phpmyadmin //安装phpmyadmin vim /etc/httpd/conf.d/phpMyAdmin.conf //修改配置文件允许远程连接 # Apache 2.4 AddDefaultCharset …

Ubuntu 18.04 安装 rocket.chat

Rocket.Chat 是特性最丰富的 Slack 开源替代品之一.它支持WINDOWS和LINUX安装,今天主要和大家谈谈使用ubuntu 下使用snap来安装rocket.chat,只需要几个简单步骤就能安装好。 ubuntu 18.04 是基于Debian基础之上构建的操作系统,而Debian使用的是APT包管理,所以只需要几个简单的apt命令即可 sudo apt update /更新apt源 sudo apt install snapd /安装snap包 sudo snap install rocketchat-server /安装rocketchat 此时使用IP:3000 就可以正常访问了,并进行初始帐号配置 如果你想使用域名并开启SSL,也仅需要几步简单命令即可, 这里我们主要用到Let’s Encrypt 这个免费的SSL加密服务 sudo snap …

wordpress插件hypercomments 未经认证用户随意更新网站配置

由于这个插件已经于2019年被wordpress团队以安全理由停止下载,所以我这里直接贴出漏洞详情 在插件的hc_request_handler.php下hc_request_handler()函数 function hc_request_handler() { global $post; global $wpdb; if(empty($_GET[‘hc_action’])) return; switch ($_GET[‘hc_action’]) …… case ‘update_options’: $options = (array)json_decode(stripslashes($_POST[‘data’])); foreach ($options as $key => $value) { update_option($key, $value); } echo …

Freemius Library < 2.2.4 - Subscriber+ Arbitrary Option Update

在查看更多的插件和主题后,发现了2个主题和更多的插件存在Freemius Library 未更新的情况,从而导致了低权限用户可以任意更改网站配置 after i looked into more plugins,i found the same vulnerability for other plugins and they are available for download Turbo Widgets Revolution for Elementor Social Gallery Lite …

wordpress插件press-elements Vulnerabilities 漏洞

press-elements 是wordpress一个比较流行的插件,但因为某种原因,该插件已经于2021年停止更新,今天ptsfense 在日常的安全检测中发现了这个插件一个致命的漏洞,插件中使用了过时的Freemius库,该库在2019年的时候已经爆出致命漏洞,使用低级别的用户可以随意更改网站的设置,该漏洞全网首发,以下为英文版说明:The plugin is using an outdated version of the Freemius library (1.2.3), which is known to be affected by a security issue allowing any authenticated users, such as …

cpanel for linux centos 7—Unable to create /etc/selinux/config

今天在一台新的机器上面安装cpanel,准备工作一切顺利,可是当开始安装cpanel的时候一直出现Unable to create /etc/selinux/config,查看了selinux策略显示enable,虽然是root用户,但却无法chome 777权限,显示Permission denied,查看了很多网上教程,大多数解决方案是把selinux的策略关闭后重新安装,可是编辑 /etc/selinux/config 根本无法编辑,同样显示permission denied,最近在google上找到答案,先把解决方案发出来:   lsattr /etc/selinux/config —-i——–e- /etc/selinux/config if you see this: chattr -i /etc/selinux/config   是因为SELinux/config的特殊的文件权限。chattr(更改属性)是一个命令行Linux实用程序,用于在Linux系统中设置/取消设置文件的某些属性,以确保意外删除或修改重要文件和文件夹。

Reverse IP Lookup–同服网站检测

一台服务器或者虚拟主机上往往放置了很多个网站,所以通过某个特定IP或者网址,查询同服的网站,那查询完用来干什么?从事安全方面的应该都懂得,如果一个特定目标安全防范做得比较好,没有明显的漏洞,那有时候通过旁站进入后提权整台服务器的思路就出来了,所以 ptsfence 建议如果对安全方面考虑比较严格的网站主最好还是购买独立IP,这是最简单经济的解决办法,因为你的安全做得再好不代表别人也是同样的想法. 现在早期很多利用bing API查询的小工具已经都失效了,国外很多提供此服务的网站和工具,本人测试后目前查询效果比较好的推荐:https://dnslytics.com/reverse-ip 免费版可以查看100个同服域名,超过的则需要付费版

wordpress插件安全漏洞—wordpress plugin vulnerabilities

wordpress是目前世界上使用最多的CMS,而各种插件也是琳琅满目,质量参差不齐,这就造成很多插件存在安全漏洞,从而导致网站被控制,接下来我将会把我的业余时间花在对wordpress插件安全漏洞的学习上面,业精于勤荒于嬉,希望自己有限的精力和时间可以对wordpress社区及插件安全做出自己一点点的贡献,因为漏洞发布涉及很多程序及合理性的问题,个人目前没有时间去直接和插件者开发者联系,所以接下来主要会发布到patchstack.com,这也是一个专门为wordpress安全提供服务的安全公司。